server move

Powerfull XFileSharing version

Moderator: admin

Message
Author
tommylee
Posts: 10
Joined: Aug 28, 2009 3:16 pm

server move

#1 Postby tommylee » Dec 23, 2010 1:13 am

Hi,

I have moved my server to another host. Copied all folders with tar files including all permissions and used wget to pull the files from new server than I have untarred all files.

I expected all to be fine but sadly not.

I cannot seem to find what can be wrong.

users can not upload new files even though it seems possible to download files.

also I can not edit server details

I get this error when I submit.

Code: Select all

File Server tests:
api.cgi: ERROR (500 Can't connect to www.xxxxx.com:80 (connect: Permission denied) )
upload.cgi: ERROR (problems with link)
htdocs URL accessibility: ERROR (should see XFS on link)


(I have edited the domain part so it is actualy correct domain)

I can clink on the both links above and I see XFS without problem.

I have check folders and files for 755 no problems so far.

So what should I do nowö any sugegstionsç

Thank you

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Dec 23, 2010 2:46 pm

Try to run this from root console on fileserver:

Code: Select all

echo 0 > /selinux/enforce

tommylee
Posts: 10
Joined: Aug 28, 2009 3:16 pm

#3 Postby tommylee » Dec 23, 2010 10:37 pm

PilgrimX182 wrote:Try to run this from root console on fileserver:

Code: Select all

echo 0 > /selinux/enforce


perfect. it worked. thank you.

I guess I have to keep it turned off, I had not noticed that I had it off in my previous system.

thank you once again, I wish I asked for help before spending couple of days to solve it by myuself and keeping the server half down during that time :)

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#4 Postby PilgrimX182 » Dec 24, 2010 8:38 am

Yea, this is weird linux mod called SELinux, paranoid security thing :)
You can edit file /etc/selinux/config
and set there

Code: Select all

SELINUX=disabled

so after reboot system will be fine.


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests