Two Vertical Scroll Bars When Adding Form To Existing Page

XUpload related questions

Moderator: admin

Message
Author
jeffshead
Posts: 18
Joined: Apr 21, 2009 3:26 pm

Two Vertical Scroll Bars When Adding Form To Existing Page

#1 Postby jeffshead » Apr 21, 2009 5:30 pm

I basically copied the code in the 'upload_form.html' tags and added the code to the proper tags in a pre-existing web page.

Everything works, but I get two vertical scroll bars on the right side of the screen as pictured below:
Image

The inner scroll bar cuts off text on the bottom of the page. The other scroll bar is the normal one always seen on IE7 windows.

The inner scroll bar is always visible unless I remove the following HTML code:

Code: Select all

body{margin:0px;height:auto;overflow:auto;}


But, the inner scroll bar is made visible again after a file is uploaded. It also does this in FF3 and Opera, but not in Safari.

An extra browse input box also appears on the left side when I use Opera and Safari. This also happens when I use the unaltered 'upload_form.html'.

Here is a pic:
Image

Anyone have any ideas on getting rid of the scroll bars and the extra browse box?

...
UPDATE: The extra browse input box issue was fixed here.
...
Last edited by jeffshead on May 01, 2009 5:29 am, edited 1 time in total.

jeffshead
Posts: 18
Joined: Apr 21, 2009 3:26 pm

#2 Postby jeffshead » Apr 28, 2009 10:59 pm

Anyone?

I've tried editing and removing parts of the styles and JS file and I tried adding the code as a php include. I just can't figure this out.

The page is not long enough to require a scroll bar much less two of them.

larrymcp
Posts: 5
Joined: Apr 29, 2009 3:46 am

#3 Postby larrymcp » Apr 30, 2009 10:30 pm

I have not seen the two scroll bars occurring on my own installation. If I do see it at some point, I'll post back here with a solution but so far I can't duplicate it.

jeffshead
Posts: 18
Joined: Apr 21, 2009 3:26 pm

#4 Postby jeffshead » Apr 30, 2009 10:34 pm

Thanks Larry.

I even rebuilt the page from scratch and I get the same results.

I'm just stumped.

larrymcp
Posts: 5
Joined: Apr 29, 2009 3:46 am

#5 Postby larrymcp » Apr 30, 2009 11:16 pm

Are you sure that page on your site doesn't have any frames in it? It looks like there's some type of frame stuff going on at the bottom; I wonder if that could be it?

jeffshead
Posts: 18
Joined: Apr 21, 2009 3:26 pm

#6 Postby jeffshead » May 01, 2009 5:22 am

Larry,

No, I don't use iframes.

If I totally remove the following line...

Code: Select all

body{margin:0px;height:auto;overflow:auto;}

... from the page, the second, inner scroll bar does not appear until after I upload something or after I attempt to upload something and canel the upload.

It's as if the page height is specified (which it is not) to a height minus the extra height required to avoid a scroll bar. You know how you have to add a little extra height to a pop up sometimes to avoid scroll bars. If that makes sense to you.

larrymcp
Posts: 5
Joined: Apr 29, 2009 3:46 am

#7 Postby larrymcp » May 01, 2009 4:35 pm

Right, yeah I've seen that situation... strange though; the solution isn't immediately obvious. I will be the first one to post back on this thread if I see it during our own implementation though. I work with a whiz-kid web guy who could probably figure it out (but only if it happens to occur here too).

jeffshead
Posts: 18
Joined: Apr 21, 2009 3:26 pm

#8 Postby jeffshead » May 01, 2009 7:13 pm

Thanks Larry.

I hope you don't run into the same issue. Please let me know if your "whiz-kid" has any ideas.


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests