XUpload - Uploading 120MB+ 'Upload Failed'

Message
Author
navc83
Posts: 7
Joined: Jul 17, 2007 5:05 pm

Uploading 120MB+ 'Upload Failed'

#1 Postby navc83 » Jun 28, 2008 1:30 pm

I'm trying to upload a 700MB file, it keeps stopping around 80MB to 170MB.

I've got my own server with a hosting company but they said this:

'Although there isn't a set execution time, any given CGI or PHP process has the following hard limits applied to it: 120 seconds of CPU time / 100MB of RAM usages'

My upload stream is average 73 Kbytes/Sec. It seems to cut out around the 30minute to 40 minutes mark, i've tested it on other computers what ever the upload rate it always spends 20 - 38 minutes uploading before cutting out. I also tried the original script on another hosting company and i had the same problem there.

Link to test: http://www.njsolutions.co.uk/upload_form.html
Script Type: Xupload Pro (Purchased September)
OS: Vista & XP
Browser: IE7 and Firefox

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#2 Postby PilgrimX182 » Jun 30, 2008 6:29 am

This also could be mod_security module upload filesize limitation.

navc83
Posts: 7
Joined: Jul 17, 2007 5:05 pm

#3 Postby navc83 » Jun 30, 2008 8:20 am

would this mean i would need to include .htaccess file? If so, i did initially but still no luck so now i've been modifying the .htaccess file which now looks like this:

-------------------------------------------------------
<IfModule mod_security.c>

SetEnvIfNoCase Content-Type \
"^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
<IfModule worker.c>

StartServers 2
MaxClients 300
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0
MaxKeepAliveRequests 800
</IfModule>


<IfModule mod_gzip.c>
mod_gzip_on No
</IfModule>

-----------------------------------------------------------


Return to “XUpload”



Who is online

Users browsing this forum: No registered users and 0 guests